import Foundation
let pattern = #"questions\/([0-9A-Za-z]+?)\/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://stackoverflow.com/questions/24a34b83c72/js-regex-get-values-between-two-characters"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}