#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((\s*(([\w_\/-]+)\s)((\bPHONE_NUMBER\b)|(\b(IP|EMAIL)_ADDRESS\b))\s*))(;|$)(?1)*)"
Local $sString = "/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS" & @CRLF & _
"/tests/phone PHONE_NUMBER /tests/IP IP_ADDRESS" & @CRLF & _
"" & @CRLF & _
"/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS ; /tests/IP IP_ADDRESS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")