using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((\s*(([\w_\/-]+)\s)((\bPHONE_NUMBER\b)|(\b(IP|EMAIL)_ADDRESS\b))\s*))(;|$)(?1)*)";
string input = @"/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS
/tests/phone PHONE_NUMBER /tests/IP IP_ADDRESS
/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS ; /tests/IP IP_ADDRESS";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}