const regex = /^(((\s*(([\w_\/-]+)\s)((\bPHONE_NUMBER\b)|(\b(IP|EMAIL)_ADDRESS\b))\s*))(;|$)(?1)*)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((\\s*(([\\w_\\\/-]+)\\s)((\\bPHONE_NUMBER\\b)|(\\b(IP|EMAIL)_ADDRESS\\b))\\s*))(;|$)(?1)*)', 'mg')
const str = `/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS
/tests/phone PHONE_NUMBER /tests/IP IP_ADDRESS
/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS ; /tests/IP IP_ADDRESS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}