re = /^(((\s*(([\w_\/-]+)\s)((\bPHONE_NUMBER\b)|(\b(IP|EMAIL)_ADDRESS\b))\s*))(;|$)(?1)*)/m
str = '/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS
/tests/phone PHONE_NUMBER /tests/IP IP_ADDRESS
/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS ; /tests/IP IP_ADDRESS'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end