import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((\\s*(([\\w_\\/-]+)\\s)((\\bPHONE_NUMBER\\b)|(\\b(IP|EMAIL)_ADDRESS\\b))\\s*))(;|$)(?1)*)";
final String string = "/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS\n"
+ "/tests/phone PHONE_NUMBER /tests/IP IP_ADDRESS\n\n"
+ "/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS ; /tests/IP IP_ADDRESS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}