// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((\s*(([\w_\/-]+)\s)((\bPHONE_NUMBER\b)|(\b(IP|EMAIL)_ADDRESS\b))\s*))(;|$)(?1)*)").unwrap();
let string = "/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS
/tests/phone PHONE_NUMBER /tests/IP IP_ADDRESS
/tests/phone PHONE_NUMBER ; /tests/IP IP_ADDRESS ; /tests/IP IP_ADDRESS";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}