import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\s]*(\\s{2,}[^\\s].*){2,}";
final String string = "Applications 7 days 6 days\n"
+ "Applications 7 days 6 days 5 days\n"
+ "Applications x y z 7 days 6 days\n"
+ "Applications x y z 7 days 6 days 5 days";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}