import Foundation
let pattern = #"^[^\s]*(\s{2,}[^\s].*){2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Applications 7 days 6 days
Applications 7 days 6 days 5 days
Applications x y z 7 days 6 days
Applications x y z 7 days 6 days 5 days
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}