re = /^[^\s]*(\s{2,}[^\s].*){2,}/m
str = 'Applications 7 days 6 days
Applications 7 days 6 days 5 days
Applications x y z 7 days 6 days
Applications x y z 7 days 6 days 5 days'
# Print the match result
str.match(re) do |match|
puts match.to_s
end