using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""col-xs-6 col-sm-4 col-md-4 col-lg-4"">(.*?)<\/div>";
string input = @"<div class=""col-xs-6 col-sm-4 col-md-4 col-lg-4"">(NÚMERO ILIMITADO DE CARACTERES)</div>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}