// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?si)<div class="col-xs-6 col-sm-4 col-md-4 col-lg-4">(.*?)<\/div>"#).unwrap();
let string = "<div class=\"col-xs-6 col-sm-4 col-md-4 col-lg-4\">(NÚMERO ILIMITADO DE CARACTERES)</div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}