$re = '/<div class="col-xs-6 col-sm-4 col-md-4 col-lg-4">(.*?)<\/div>/si';
$str = '<div class="col-xs-6 col-sm-4 col-md-4 col-lg-4">(NÚMERO ILIMITADO DE CARACTERES)</div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);