const regex = /<div class="col-xs-6 col-sm-4 col-md-4 col-lg-4">(.*?)<\/div>/si;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="col-xs-6 col-sm-4 col-md-4 col-lg-4">(.*?)<\\\/div>', 'si')
const str = `<div class="col-xs-6 col-sm-4 col-md-4 col-lg-4">(NÚMERO ILIMITADO DE CARACTERES)</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}