import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"col-xs-6 col-sm-4 col-md-4 col-lg-4\">(.*?)<\\/div>";
final String string = "<div class=\"col-xs-6 col-sm-4 col-md-4 col-lg-4\">(NÚMERO ILIMITADO DE CARACTERES)</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}