re = /<div class="col-xs-6 col-sm-4 col-md-4 col-lg-4">(.*?)<\/div>/i
str = '<div class="col-xs-6 col-sm-4 col-md-4 col-lg-4">(NÚMERO ILIMITADO DE CARACTERES)</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end