#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^|]*\|\|"
Local $sString = "HJH3123|||38|323|h38|0|84" & @CRLF & _
"HJH3123|332|44|38|323|h38|0|84" & @CRLF & _
"HJH3123|4431||38|323|h38|0|84" & @CRLF & _
"HJH3123|4431|33|38||h38|0|84" & @CRLF & _
"HJH3123||38|323|h33|2|85"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")