use strict;
my $str = 'HJH3123|||38|323|h38|0|84
HJH3123|332|44|38|323|h38|0|84
HJH3123|4431||38|323|h38|0|84
HJH3123|4431|33|38||h38|0|84
HJH3123||38|323|h33|2|85';
my $regex = qr/^[^|]*\|\|/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}