$re = '/^[^|]*\|\|/m';
$str = 'HJH3123|||38|323|h38|0|84
HJH3123|332|44|38|323|h38|0|84
HJH3123|4431||38|323|h38|0|84
HJH3123|4431|33|38||h38|0|84
HJH3123||38|323|h33|2|85';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);