using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^|]*\|\|";
string input = @"HJH3123|||38|323|h38|0|84
HJH3123|332|44|38|323|h38|0|84
HJH3123|4431||38|323|h38|0|84
HJH3123|4431|33|38||h38|0|84
HJH3123||38|323|h33|2|85";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}