re = /^[^|]*\|\|/m
str = 'HJH3123|||38|323|h38|0|84
HJH3123|332|44|38|323|h38|0|84
HJH3123|4431||38|323|h38|0|84
HJH3123|4431|33|38||h38|0|84
HJH3123||38|323|h33|2|85'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end