const regex = /^[^|]*\|\|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^|]*\\|\\|', 'gm')
const str = `HJH3123|||38|323|h38|0|84
HJH3123|332|44|38|323|h38|0|84
HJH3123|4431||38|323|h38|0|84
HJH3123|4431|33|38||h38|0|84
HJH3123||38|323|h33|2|85`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}