#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^|\(| or | and )(?:(?<left>"[^"]*")|(?<left1>(?:"[^"]*"|(?!\(| or | and ).)*?)) matches (?:(?<right>"[^"]*")|(?<right1>(?:"[^"]*"|(?!\(| or | and ).)*?))(?=\)|$| and | or )"
Local $sString = ""abc" matches "b" and field[cba] = "cba" or (field[cba] matches "c") and "cc" = "bb"" & @CRLF & _
"" & @CRLF & _
"("abc and def" matches field["efg"]) or field[cba] matches field["cba"]" & @CRLF & _
"" & @CRLF & _
"field["abc"] in field matches field["cba"] in field"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")