use strict;
my $str = '"abc" matches "b" and field[cba] = "cba" or (field[cba] matches "c") and "cc" = "bb"
("abc and def" matches field["efg"]) or field[cba] matches field["cba"]
field["abc"] in field matches field["cba"] in field';
my $regex = qr/(?<=^|\(| or | and )(?:(?<left>"[^"]*")|(?<left1>(?:"[^"]*"|(?!\(| or | and ).)*?)) matches (?:(?<right>"[^"]*")|(?<right1>(?:"[^"]*"|(?!\(| or | and ).)*?))(?=\)|$| and | or )/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}