import Foundation
let pattern = #"(?<=^|\(| or | and )(?:(?<left>"[^"]*")|(?<left1>(?:"[^"]*"|(?!\(| or | and ).)*?)) matches (?:(?<right>"[^"]*")|(?<right1>(?:"[^"]*"|(?!\(| or | and ).)*?))(?=\)|$| and | or )"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"abc" matches "b" and field[cba] = "cba" or (field[cba] matches "c") and "cc" = "bb"
("abc and def" matches field["efg"]) or field[cba] matches field["cba"]
field["abc"] in field matches field["cba"] in field
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)