using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\(| or | and )(?:(?<left>""[^""]*"")|(?<left1>(?:""[^""]*""|(?!\(| or | and ).)*?)) matches (?:(?<right>""[^""]*"")|(?<right1>(?:""[^""]*""|(?!\(| or | and ).)*?))(?=\)|$| and | or )";
string input = @"""abc"" matches ""b"" and field[cba] = ""cba"" or (field[cba] matches ""c"") and ""cc"" = ""bb""
(""abc and def"" matches field[""efg""]) or field[cba] matches field[""cba""]
field[""abc""] in field matches field[""cba""] in field";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}