const regex = /(?<=^|\(| or | and )(?:(?<left>"[^"]*")|(?<left1>(?:"[^"]*"|(?!\(| or | and ).)*?)) matches (?:(?<right>"[^"]*")|(?<right1>(?:"[^"]*"|(?!\(| or | and ).)*?))(?=\)|$| and | or )/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\(| or | and )(?:(?<left>"[^"]*")|(?<left1>(?:"[^"]*"|(?!\\(| or | and ).)*?)) matches (?:(?<right>"[^"]*")|(?<right1>(?:"[^"]*"|(?!\\(| or | and ).)*?))(?=\\)|$| and | or )', 'gm')
const str = `"abc" matches "b" and field[cba] = "cba" or (field[cba] matches "c") and "cc" = "bb"
("abc and def" matches field["efg"]) or field[cba] matches field["cba"]
field["abc"] in field matches field["cba"] in field`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}