$re = '/(?<=^|\(| or | and )(?:(?<left>"[^"]*")|(?<left1>(?:"[^"]*"|(?!\(| or | and ).)*?)) matches (?:(?<right>"[^"]*")|(?<right1>(?:"[^"]*"|(?!\(| or | and ).)*?))(?=\)|$| and | or )/m';
$str = '"abc" matches "b" and field[cba] = "cba" or (field[cba] matches "c") and "cc" = "bb"
("abc and def" matches field["efg"]) or field[cba] matches field["cba"]
field["abc"] in field matches field["cba"] in field';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);