# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:.*\/|\G)\K(\S+)\s+(?![^\/]*\/)/$1_/gm;t' <<< "./ringtones 1 space test/R2D2.mp3
foo bar abc def/Test Input File"