const regex = new RegExp('(?:.*/|\\G)\\K(\\S+)\\s+(?![^/]*/)', 'gm')
const str = `./ringtones 1 space test/R2D2.mp3
foo bar abc def/Test Input File`;
const subst = `$1_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);