use strict;
my $str = './ringtones 1 space test/R2D2.mp3
foo bar abc def/Test Input File';
my $regex = qr~(?:.*/|\G)\K(\S+)\s+(?![^/]*/)~mp;
my $subst = '$1_';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";