using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.*/|\G)\K(\S+)\s+(?![^/]*/)";
string substitution = @"$1_";
string input = @"./ringtones 1 space test/R2D2.mp3
foo bar abc def/Test Input File";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}