import Foundation
let pattern = #"(?:.*/|\G)\K(\S+)\s+(?![^/]*/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
./ringtones 1 space test/R2D2.mp3
foo bar abc def/Test Input File
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)