$re = '~(?:.*/|\G)\K(\S+)\s+(?![^/]*/)~m';
$str = './ringtones 1 space test/R2D2.mp3
foo bar abc def/Test Input File';
$subst = "$1_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;