#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "Watch (\w*)'s video"
Local $sString = "Watch Sidney's video"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)