const regex = /Watch (\w*)'s video/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Watch (\\w*)\'s video', 'g')
const str = `Watch Sidney's video`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);