use strict;
my $str = 'Watch Sidney\'s video';
my $regex = qr/Watch (\w*)'s video/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";