import re
regex = re.compile(r"Watch (\w*)'s video")
test_str = "Watch Sidney's video"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)