re = /Watch (\w*)'s video/
str = 'Watch Sidney\'s video'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result