# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/&(?!(?:#[0-9]+|[a-z]+);)//gm;t' <<< "The apple, orange & lemon
Peter & Mary
B&B
He & I went;
&
p
"