const regex = /&(?!(?:#[0-9]+|[a-z]+);)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('&(?!(?:#[0-9]+|[a-z]+);)', 'gm')
const str = `The apple, orange & lemon
Peter & Mary
B&B
He & I went;
&
p
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);