import Foundation
let pattern = ##"&(?!(?:#[0-9]+|[a-z]+);)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
The apple, orange & lemon
Peter & Mary
B&B
He & I went;
&
p
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)