use strict;
my $str = 'The apple, orange & lemon
Peter & Mary
B&B
He & I went;
&
p
';
my $regex = qr/&(?!(?:#[0-9]+|[a-z]+);)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";