import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "&(?!(?:#[0-9]+|[a-z]+);)";
final String string = "The apple, orange & lemon\n"
+ "Peter & Mary\n"
+ "B&B\n"
+ "He & I went;\n"
+ "&\n"
+ "p\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}