$re = '/&(?!(?:#[0-9]+|[a-z]+);)/m';
$str = 'The apple, orange & lemon
Peter & Mary
B&B
He & I went;
&
p
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;