#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "https?://\S*?co|\b(co)\b"
Local $sString = "cots and co http://me.co.uk last of my co."
Local $sSubst = "<a href='/co'>co</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)