$re = '~https?://\S*?co|\b(co)\b~';
$str = 'cots and co http://me.co.uk last of my co.';
$subst = "<a href='/co'>co</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;