import re
regex = re.compile(r"https?://\S*?co|\b(co)\b")
test_str = "cots and co http://me.co.uk last of my co."
subst = "<a href='/co'>co</a>"
result = regex.sub(subst, test_str)
if result:
print(result)