re = /https?:\/\/\S*?co|\b(co)\b/
str = 'cots and co http://me.co.uk last of my co.'
subst = '<a href=\'/co\'>co</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result