// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?://\S*?co|\b(co)\b").unwrap();
let string = "cots and co http://me.co.uk last of my co.";
let substitution = "<a href='/co'>co</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}